A* Pathfinding Project

4.3.16 - Pathfinder Editor not working + Recast complaining about read access?


#1

Hi,

today I tried integrating A* pathfinding project into one of our new projects. I found two issues:

  1. We installed 4.3.16 via package manager. However: We can’t access the inspector for the Pathfinder.

  2. Before I used 4.3.15 - There I had the problem when scanning the Recast graph via script it threw an exception where it complained about meshes not being read/write enabled. Is it really required for all meshes used? When I scanned in the editor via “Scan” button it worked.

Not allowed to access triangles/indices on mesh 'zaun_17' (isReadable is false; Read/Write must be enabled in import settings)

Best regards
Bennet


#2

Thanks for reporting this. I have uploaded 4.3.17 now which fixes this.

Yes. If read/write is disabled there is no way for the package to read the meshes at all, so they cannot be used to generate the graph. See the bottom of this page for a longer explanation with alternatives: https://arongranberg.com/astar/docs/errormessages.html


#3

Ok, thanks! 4.3.17 works.