2D: Unwalkable Nodes inside of tilemap with Composite Collider

I have a very simple scene with 2 Tilemaps (Ground and Walls). The walls have a Tilemap Collider 2D with Composite. The Layer is set to “Walls”, which is also the Obstacle Layer Mask.

But I have the problem, that I have unwalkable Tiles/Nodes inside of my tilemap, although there is no Wall-Tile and also no collider attached.

I only want the wall to be “unwalkable”


It might be that the collision check just touches the wall collider. Try to either reduce the Grid Graph -> Collision Testing -> Diameter setting or set the Collider Type to Point.

1 Like

Thanks. I already tried it, but it seems I reduced the Diameter to much. A value of 0.97 works fine.

Anything lower, and everything was passable (no unwalkable tiles), but I can’t reproduced it now.

1 Like