[2D Toolkit] Grid detects all paths as walkable

I made a tilemap in 2D Toolkit (with colliders, see image). I made their collider-z-size extremely large just to be sure.
I rotated the grid-graph by 90 degrees and changed the climbing axis. The seekers are able to find the player. But… The grid thinks that everything is walkable. Both the colliders and the grid-mask are set to “Obstacles”.
What did I overlook? Also I couldn’t find a tutorial for a simple getting started for 2D topdown XY-axis only.

I’m not allowed to put images in posts as a new user and only 2 urls… So just paste the urls below into the browser.

Also the tilemap collisions work because the player can’t move through them, nor can the seekers. But why does the pathfinding not detect those colliders as non-walkable?

http:// s11.postimg.org/iycb8f30j/onlywalkable.png

http:// s21.postimg.org/swlf62lcn/settings.png

http:// s10.postimg.org/j5q0wks2x/obstacles.png

The steps described in this topic: How do I integrate A* with 2D Toolkit’s Tilemaps?
do not work. I set it to 3D and tried rotating the grid over the negative x-axis (instead of the positive one) but it didn’t solve it. Still fully walkable.

If I set the collider type to Ray and then back to sphere (with 2d physics checked) and then hit Scan, it still uses rays. It seems to bug. I have to delete the entire A* path script for it to work again with spheres. I don’t think this is even related to the 2dtoolkit, it’s probably just a bug.

Unchecking “Use 2D Physics” made it work (this time, didn’t work before)… I don’t understand why. There is some bug somewhere related to this because the other post also mentions some problems regarding this.

Sorry for the delayed reply.
Did you manage to get it to work in the end?