Navmesh cut not applied to certain objects


Hey there! Is there a method to have to have navmesh cuts NOT apply to certain objects? I’m hoping to determine a way to have my players/NPCs not pass through each other.



For that you would usually not modify the pathfinding graph at all, instead you would use some kind of local avoidance. One kind is included in this package. See

If you have a player character that is manually controlled (e.g using WASD keys), you can attach an RVOController to the player as well, and then make other agents aware of where you want it to move by setting RVOController.velocity.