Got Stuck in Example


#1

After importing, the first thing I did was open the Example 2 scene. I used the mouse to direct the little bot around. However, when I moved the bot over to the hilly terrain near the lake, it got stuck. No matter where I moved the mouse or clicked around (even the flat area where it started out), the bot wouldn’t move an inch. I got the “Path Failed” message in the console. I tried it a couple more times and I wasn’t able to reproduce it so there’s that. I wanted to test how this asset worked on bumpy terrain and slopes so I jiggling it around all over there for a while before that happened. Any idea what happened and how I could avoid that in the future?


#2

Hi

It is possible that the bot due to physics and its inertia ended up inside one of the really small areas on the hillside that aren’t connected to anything else. From there it wouldn’t be able to move anywhere.
That is a slight problem with that example scene. The grid that is generated is not very clean in the hills. It can be mostly fixed by increasing the erosion setting in the grid graph settings though.