Gizmos not drawing in 2D project


#1

Hi everyone! First of all, this lib looks like it does exactly what i want and seems really easy to use :slight_smile:

But I’m having an issue. I currently use Unity 2017.3.1f1 and A* 4.1.16.
I followed the beginners guide and followed the steps. Created an A* object and attached the script. But nothing showed up. I opened the already created 2D examples (Example 15 and 12) and also nothing showed up.
I have all gizmos enabled and Show surface outline and connections on. I can see gizmos created by me and by another package i’m using, but nothing shows up for this one :sweat:

What am i doing wrong?

This is my project tree. The Main folder is my project, Gizmos and Anima 2D other package, and the AStar remains untouched. Should i reorganize or enable/disable something?

Thanks for the help


#2

Is the global ‘Show Graphs’ toggle enabled? (bottom of the A* Inspector)


#3

Forgot to mentions yes, and i scanned the grid graph after i calculated just to make sure i had some nodes


#4

Ok I don’t know what i did but it started showing all of a sudden! Maybe i moved them to a position i couldn’t see. Anyway thanks for the very quick reply! :smiley: