Version of A*PP in video tutorial

Hi there, i am not very experienced user of your pathfinder and i dont really want to spend too much time with it, just want to make it work. I am trying to implement pathfinder as it was shown to me in this video The problem is that in tutorial you dragged target object to transform area in “AI Path” script inspector and in actual version there is no place to drag target in. I also tried to drag my target to “Target Mover” script but that doesnt worked. My question is what version were you using in that tutorial or how to attach target in actual version? My project need to stay 2D.
With regards


Right. I have made an updated version of the get started tutorial, but not yet the 2D tutorial.
The only change you need to make is that you need to add the AIDestinationSetter component to the same GameObject as your AIPath script. The reason for this change is that the scripts no longer require the destination to be a Transform object, you can pass in any Vector3 by setting ai.destination.

1 Like

I’m having the same problem, I have watched the latest video, and I’m not able to resize as described here:

I’m using the latest free version.

Screenshot added:



That’s the wrong resize button. You should use the one for 3D resizing (it’s the one to the left of the one you have selected).

@aron_granberg I already have tried all buttons and I still not able to resize :frowning:

Looks like I found the problem, the position of the A* object need be 0, 0, 0, only there I can see the resize anchor.

There is no other way to drop this in another position?