Upgrading version throws namespace errors


First of all, thank you Aron for a great asset.
When I first bought the asset around 2 weeks ago I installed it from the asset store. For some reason that version didn’t include the “AIPathAlignToSurface”-script which I needed so I got the latest beta from the website instead.

I’ve followed the upgrade guide but I still get errors.

Here is a list of other stuff I’ve tried:

Deleting the whole Astarpathfinding project file and installing it again.

Using “Regenerate project files” in Preferences/External Tools.

Updating rider.

Upgrading to the latest LTS version of Unity.

Renaming the classes that throws the errors.

Putting the classes that throws errors in their own namespace.

Tried different beta versions of the AstarPathfindingProject.

I’m out of ideas of what to try next. Hopefully someone got a solution to my problem!


Do you use assembly definition files? If so, you may need to add the .asmdef files in the A** package as a dependencies.

I do not, atleast I don’t think so. I’m fairly new to programming so I can’t be a 100% sure. But I have not messed with anything like that.

I found this when I open the asmdef file, an error with the jobs package. Could it have something to do with that?

I downloaded jobs in package manager using add from git: com.unity.jobs.
And now it works!
Thank you for helping me trouble shoot!

1 Like