Upgrading to A* Pro Errors

I tried to update my A* pathfinding package to the latest version (pro) and is showing up with a range of errors any help would be greatly appreciated.

the above are the 28 total errors they stem from mostly the same places.
Thanks in advance.


Did you follow the installation guide: Installation Guide - A* Pathfinding Project
More specifically, did you remove your previous installation before upgrading?

Yeah I have i must be going wrong somewhere though tried to import it into a blank project and still didn’t work and tried to upgrade it from a old version in the methods you suggested which failed as well with the errors above

Which version of Unity are you using?

the version is 2022.3.22f1

That’s strange. It didn’t work in a completely fresh project? You are importing it from the asset store like in the installation guide? Not installing it from any other source.
2022.3.22f1 is a supported version.

I finally worked it out i was just being dumb sorry, thanks