Upgrading from to 3.8.11 introduced teleporting issues when recycling pooled AI agents

Hi, I am trying to solve crash issues that a small number of my user base is experiencing. I figure I would try updating A* to see if it would help.

After updating when I recycle an enemy they often teleport back where they died / at the player. In the older version I was moving them directly with transform. I tried utilizing the RVOController teleport function after upgrading but I was unable to prevent the teleport issue. I have seen this issue mentioned before but was unable to find a solution searching through the forums.

My AI use the RichAIAgent, Seeker, and RVOController. I recall having this issue when I first started the project but with some tinkering got it to stop. Unfortunately that Was almost a year ago and I can’t recall what fixed it.

I also went ahead and bought the new 4.0 version (I’m in a bit of a hurry trying to make improvements to a live product) but ran into other errors that I think had to do with issues between behavior designer’s movement pack and the new version. For now, I will have to revert back to If you think the updates wouldn’t fix any rare crash issues then I can just keep using the older version I suppose.


Yeah, this bug was introduced at some point (I’m not sure which version number). It has been fixed in the 4.1 beta, however as you say the movement pack might not be compatible with that.

I think the it is not that hard to get it working in 3.8.11 though. You could try to open the RichAI.cs script and add the line

rp = null;

to the start of the OnEnable method.