Updated A* and got a bunch of errors


I have been using a few months old version and now I downloaded the newest one from the asset store, and I get these errors, any help would be appreciated

Assets/AstarPathfindingProject/Legacy/Editor/LegacyAIPathEditor.cs(6,36): error CS0246: The type or namespace name `BaseAIEditor’ could not be found. Are you missing an assembly reference?

Assets/AstarPathfindingProject/Legacy/Editor/LegacyRichAIEditor.cs(6,36): error CS0246: The type or namespace name `BaseAIEditor’ could not be found. Are you missing an assembly reference?

Assets/AstarPathfindingProject/Legacy/Editor/LegacyRVOControllerEditor.cs(6,59): error CS0234: The type or namespace name RVOControllerEditor' does not exist in the namespacePathfinding.RVO’. Are you missing an assembly reference?

Assets/AstarPathfindingProject/Legacy/Editor/LegacyAIPathEditor.cs(7,27): error CS0115: `Pathfinding.Legacy.LegacyAIPathEditor.Inspector()’ is marked as an override but no suitable method found to override

Assets/AstarPathfindingProject/Legacy/Editor/LegacyRichAIEditor.cs(7,27): error CS0115: `Pathfinding.Legacy.LegacyRichAIEditor.Inspector()’ is marked as an override but no suitable method found to override

Assets/AstarPathfindingProject/Legacy/Editor/LegacyRVOControllerEditor.cs(7,27): error CS0115: `Pathfinding.Legacy.LegacyRVOControllerEditor.Inspector()’ is marked as an override but no suitable method found to override


This has been fixed in 4.2.2 which you can download here: https://www.arongranberg.com/astar/download. A new version has already been submitted for review to the asset store and I expect it to be approved within a few days. Unfortunately it is not possible for me to even update the text on the asset store package without it having to go through an approval process which usually takes at least a week :(. This upgrade bug wasn’t caught by any beta testers unfortunately.

Thanks, that fixed it!

I have another question, one of our users is getting this error, but no one else sees it, the navigation works fine on my PCs and other players.

Caught exception while deserializing data. There are no graphs in the scene (printed out 4 times), it happens as soon as the player approaches an animal and it sets the RichAi destination to the player position. The animal starts running forward and wont stop or follow the player.

Its a regular windows x64 build, the client uses windows 7, but I have tested on my windows 7 laptop and can’t replicate the issue.


If it says ‘Caught exception while deserializing data’ it would also have logged the actual exception just before or after that. It would be very useful to see that log message.

‘There are no graphs in the scene’ may be logged afterwards because some scripts may need to use the graphs, but since deserialization failed no graphs exist.

There is no other message except Caught exception while deserializing data

Right, checked the code. It looks like the exception should be in the same message, just after a newline.


I dont know, we use game console that keeps track of the unity log (never failed me before) and on line 12 it prints out that message, then line 13 is with the There are no graphics message
Maybe if I get rid of the new line it will show up? which script is that I can edit it real quick and test

Okay. It’s the AstarData.cs script, around line 364.

Getting the same error and nothing else, even edited it to print out e.Message

Huh. Can you print the type of the exception? Do you have any build settings that disable exceptions?

I dont think I have any build settings that do that

Okay I got more info the error message is : Input string was not in a correct format.
EDIT : Changing the computer language to EN-US fixes it… still some players might get that error…

Oh. That’s interesting.
Are you using the latest version and are able to get that error?
The json decoding uses culture invariant formats for everything as far as I can tell, but I might have missed some spot.

Yeah I am using the latest beta. His PC language was Slovenian and unless he switches to EN-US or something like that, he’s getting that error.

Okay. Is it possible for you to print the stack trace of the exception? (not the ‘Caught exception…’ error message, but the actual ‘Input string was not in a correct format’ exception.

In order to get that Input string message I had to do something like:

//Your Debug LogError

And still got only 1 line containing the incorrect format message. I guess the only way to replicate is to change your OS language to Slovenian and start the game in the editor, unfortunately, I don’t have time to do it now.

Okay. Well, if you get some time. Printing Debug.Log(e.StackTrace) would be helpful.

I am getting the following error that I did not get with Version 4.1 and earlier:

Assets/DunGen/Integration/AStarPathfindingProjectPro/AStarNavMeshAdapter.cs(55,24): error CS1061: Type AstarPath' does not contain a definition forScanLoop’ and no extension method ScanLoop' of typeAstarPath’ could be found. Are you missing an assembly reference?

This is from the DunGen procedural level generator.

The line in question:

I tried updating to 4.2.2 but that didn’t help.

What has changed and what’s the fix?


The ScanLoop method was deprecated 3 years ago (in 2015). It was removed in 4.2 (also mentioned in the changelog).
The method has been renamed to ScanAsync, so you should be able to rename the call.