RVO simulator issue

I have no idea why but the RVO simulator is lagging out my game completely. I mean as soon as there is even one enemy with RVO controller it drops fps. The weird thing is it was working fine when i was working on it and couple days later it started dropping FPS for no reason as i didnt change anything. I have already tried reimporting the asset, did not work. I have also tried removing all graphs and left just 1 and removing all obstacles.

I have found the issue which seems to be RVONavmesh obstacle, I tested this on RVO 2D example and after adding RVONavmesh to the obstacle sprites it dropped fps big time.

How does one makes agents unable to push each other to walls?


You should only have a single RVONavmesh component in the scene. It takes care of all graphs, not each individual obstacle. If you have more of them then it will try to add obstacles for the graph multiple times which will indeed be slow.

Thanks for the info. By the way what could be the reason for the AI to move really slow when i attach rigidbody to it.


That’s odd. The AIPath script just uses the rigidbody.MovePosition method so it should behave almost identically. Which version are you using?

I am using 4.0.11 version.

Also with just 6 enemies the RVO drops my fps a lot. I have no RVONavmesh anymore either

Could you make sure that you have searched the scene for any additional instances of RVONavmesh or RVOController. I don’t see how it would use that much CPU power unless you had at least hundreds of agents.

Yep it is fine now I did in fact have more RVONavmeshes. However the rigidbody speed is still an issue. Its like it was lagging every 0.5 sec it changed speed. Slow>rly slow>slow>normal>slow

Could you post a video perhaps?


Ok. I haven’t been able to replicate this. I tried to add a kinematic rigidbody to all agents in the ‘RVO’ example scene, but everything looks fine there. Are your rigidbodies are kinematic?

They arent kinematic. I have however deleted it just use the RVO with beta version now and it seems to be working fine.