A* Pathfinding Project

RVO not working for me - Beta 4.3.4


#1

Hi,

I am implementing RVO into my RTS game which involves vehicles on a point / recast graph. I have inserted both an RVOSimulator component into the scene and added RVOControllers to my two vehicles. Both vehicles have rigidbodies with box colliders on them.

The RVO system was working, but I went to remove the rigidbody components from both vehicles because I did not want the vehicles potentially impacting — I was o.k. with them ‘phasing’ through each other. After I removed these rigidbodies, the RVO system stopped working. I tried to reattach the rigidbody components but I still cannot get the local avoidance to work.

I tried 1:1 copying the RTS example scene in the beta but to no avail.

Would appreciate some guidance.


#2

Hi

The beta is a bit unstable now I’m afraid. I’m working on some fixes, but for now I would recommend using the non-beta version. Sorry for the inconvenience.


#3

Hi, no problem. I was curious as to what the issue was because in the example scene everything was working fine. Nonetheless, i switched to rts beta 4.2.8 and everything is working for me now.


#4

The issue is moving things to burst breaks a lot of stuff XD. Keeping backwards compatibility is not always trivial.