Recast Graph Scan Graph Not Correct

as the image. This stair can not generate nav graph . How can i fix it

It’s hard to say, but I think it’s likely that you need to increase the resolution of your graph. Try decreasing the ‘cell size’ field on the recast graph.

This is very pleausre receive your reply. yeah it is right when i decreasing the "cell size " the stair mesh was display. But it will be cost more time to scan which i made a game bake graph in runtime. Is there better solution or best cell size ?
Second. Although the stairs were connected by other areas, but the character could not walk up the stair. It seem like the character could not climb the stair then stuck in it’s place. What i had done is increase the “Character Controller” component’s SlopLimit to a larger number like 86. Am i made a mistake ?

Hi. Dear aron. Why all the stair always apper wrong. Is there some setting that i had not noticed ?


Are you using the beta version? If so, make sure you upgrade to the latest beta as previous betas had an issue that could generate an incorrect navmesh on stairs like that.
But also, the stair geometry may be too complex to efficiently use for generating a navmesh. If for example a part of the stair has a very high slope (e.g. part of the rounded part of a rock slab) then it might signal that this part is unwalkable, leading to holes in the navmesh. It may be better use the recast setting Rasterize Colliders instead, and use the (presumably simplified) collider mesh for the stair.