Radius field not doing anything? 2D

Basically using Astar to try the newish 2d stuff, using the free one atm.

I needed it for a 2d project, but from what I can tell the radius field in the AIPath script, isn’t doing anything.Which results in the unit getting stuck on colliders if it has a dynamic rigidbody.

VIdeo of the issue.

And yes as the 2d tutorial video explains, I tried to increase resolution and reduced the pick next waypoint distance. Issue was not solved.

Also from reading the code, I don’t even see the radius field being used anywhere outside of props. Is this due to it not being the paid version or?


The radius field on the movement scripts do not affect the pathfinding graph, but they are used for other things like local avoidance.
To change the pathfinding graph so that the agent moves further away from the wall you should change the Grid Graph -> Collision Testing -> Diameter setting (or alternatively the ‘erosion iterations’ setting).

Also make sure that your movement script doesn’t have a too high Pick Next Waypoint Distance as then it may short-circuit the path a bit.

but will result in not being able to have multiple units of different radius size no?

And as a quick question, is this a limitation of a 2d pathing, or is this also an issue in the 3d part of the Astar package?

Edit: Though I guesss you can multiple graphs of the same location for different radius as a work around.


Yes, multiple agents with different pathfinding rules need different graphs. You can take a look at this page for more information: https://arongranberg.com/astar/docs/multipleagenttypes.html