Problem with beta 4.3.90 - can't add some monobehaviors


I just upgraded to 4.3.90 to gain access to the better Layer Grid Graph, and that part is working nicely, but I just noticed now that I have an issue with some monobehaviors from the package that I can’t manage to add to my gameobjects.

As you can see, plenty of them are available to me:

But some aren’t:

Any ideas what’s going on?

The only thing that I found that seems weird is the assembly definition of the package, as there seem to be missing references? I removed and re-installed the package and that made no difference.

Thanks for your help!

The only option I found to make it work was to copy the package cache into my project, and then fix all the assembly defs manually until all the errors were resolved.

It worked, kinda…

The gizmos dont work (magenta color) and the graph itself is not displayed (should be blue all over the map).
And the editor on the right looks a bit weird as well, no borders around section headers like before, iirc.

Anyway, the goal would be to try to understand the root cause, as I’d really prefer having the package as a real package. No idea why the assembly def references are missing :frowning:

it might be a long shot but have you tried reimporting the package (right mouse click → reimport)?

I haven’t tried that specifically, I just re-imported the whole package from scratch. I’m not sure how that would not work but re-import would, but I’ll give it a shot if Aron can’t think about a solution/reason. It’s just a little bit annoying to test now that I have moved the package in the project and fixed all the dependencies, that’s the only reason I’d rather wait for a response from Aron.

Those missing references are from the Unity.Transforms and Unity.Entities packages which are optional dependencies. If you have those packages then you’ll get access to e.g. the FollowerEntity component. Otherwise it will not be available.

I’m not sure why you can’t access the Seeker, though. It should always be available. What does Unity say if you try to drag the Seeker script from the project window?

1 Like

Ok, so the missing dependencies are not the problem I guess.

I’ll try dragging the file and see what happens, good idea.

I got a similar problem (not sure if the same) and solved it by deleting the package cache.

1 Like

I appreciate the advice, I’ll give that a shot!

Thanks mate, I think that fixed it!