Path pending forever after I reload a new scene

I solved this problem, was just an issue on my end that was breaking the graph because my custom grid setup script was accidentally running twice at the same time inside IEnumerators.
Now its all working great. My original pathing script had the game at 1-5 FPS with a room full of enemies but its all golden now. Thanks.

Original problem:

Hello, when I enter the first level scene pathing is working, then after any scene change its stuck on path pending forever, even going back to the first scene where it worked initially.

Is there anything special I need to do before changing scenes and setting up a new instance of AstarPath? I tried running StopAllCoroutines on all the components in the previous scene, destroying them all, waiting 3 frames then loading the next scene. But the pathing still doesn’t work once i’ve changed scenes. When its not working, I still visibly see the generated grid, but entities just never find their path.



Have you written your own movement script? Do you get any errors in the log?
If the AstarPath component is destroyed, then all pending paths should fail with an error (the callback will be called, and path.error will be true).