Support Forum

Not Local Avoidance

How to make agents consider other agents when building path?
I saw old posts on this topic, where it is said that there is no such functionality. Has something changed?
This is a very important feature, without which the current avoidance does not make sense.
If it can’t be solved, then we will have to switch back to Unity NavMesh, where this feature is implemented.

Version - 4.2.17
Grap - Raycast
Device - Oculus Quest 2

I tried to switch to the beta version, but RVOSimulator ruins my performance in the build. And strangely, the profiling does not find a problem.The problem is present even if there are no agents on the scene.
RVOSimulator enabled - 30-50 FPS
RVOSimulator disabled - 70 FPS


Hi

Are these agents completely non-moving?

The beta version includes improved handling of RVOControllers which are “locked” (i.e. forced to be stationary). You can also use a NavmeshCut to cut out the navmesh below the agent and make other agent’s pathfinding take it into account. However then you’ll have to take care in the way you re-enable the blocking agent when you want it to start moving again, so that it doesn’t think it has to path around its own navmesh cut.

That’s weird. And yeah, I cannot see anything that sticks out in that profiler screenshot. Is this with or without the RVOSimulator?

Is it, though? Agent to agent avoidance is typically solved using local avoidance there too.

These are screenshots with RVOSimulator. Yes, I agree, it looks wierd, but when switching RVO, the difference is 20-30 fps.
I think jobs can block thread and it doesn’t show up in the profiler. Could it be?

Can I modify the release version code to added RVO from beta or would that be too complicated?

Do you have a screenshot without the RVOSimulator?

Jobs will show up in the profiler.

Way too complicated I’m afraid.

I think this was fixed in 4.3.55. But now there is an error that spawns after stopping PlayMode in the editor


Hmm… Is that the first error you get, or are there other errors or warnings before it? Can you replicate this in any example scene?

No, i can’t replicate it in empty project. I was try reimport astar, same problem in my project

Hi

I think this has been fixed now in 4.3.56.