Make the Mesh readable

After making a Build the error pops up:
“Not allowed to access vertices on mesh ‘Curve’ (isReadable is false; Read/Write must be enabled in import settings)”

For imported objects I can easily enable Read/Write via checkbox.
The problem is with 3D objects I have added right into the Scene - since they are not in the project folder, they do not have Import settings.

You are probably calling Unity - Scripting API: Mesh.UploadMeshData with a parameter of false. That will also make them non-readable.

Darn. Where do I look for it? Is it at all doable?

Well, it’s something that your code, or whatever code is generating that mesh is doing.

Hell knows…

I guess I’ll just create one in Blender and import… Jesus, all this extra work now to replace them… Heh.

OK, thank you.

But what is generating the mesh?

I don’t know.

Mu knowledge of this is non-existent :confused: I learn on the go and this is one that’s new :slight_smile: