Installing Entities 1.20 with Unity 2023.1.6f1

I’m trying to use the Follower Entity script but it requires the entities package from the package manager.

However after I install the entities package it completely breaks my project references and throws about 1000 compiler errors.

Things like Unity.Mathematics, Burst, Jobs, Float2 using statements are no longer recognized in the scripts, thus all the errors.

Has anyone experienced anything like this and have any idea how to fix it?
I reimported all
I deleted the library folder etc

If I uninstall the entities package everything works again.

According to Unity this isn’t happening and I’m the only person in the entire Universe that has this problem and I’m clearly imagining it. :slight_smile:

Hi

Not sure. I’d guess this entities package is not compatible with your version of Unity, but tbh I’m not sure.

I’ve been trying to find any information about that but all I get is 2022. something or later and it should work.

I’m using 2023.1.61f so according to everything I’ve read it should be fine.

What version of the Editor have you gotten Entities 1.20 to work on?

I’m using 2023.3 for most of my development. On that, 1.20 definitely works.

Hmm, well I finally got Unity to admit that I’m not crazy. I submitted a bug report along with a sample project reproducing the issue. If you want I can report back.

1 Like

I move my project to 2022.3.25f and that worked. I was going to try Unity 6 beta but don’t want to fight bugs in a beta version just yet.

1 Like

Hiya, just popping in to say, no, you aren’t the only one having issues with a few thousand burst errors at the moment.

It seems to be a recent thing specific with dependencies on AStar itself, as this only started happening after we upgraded from 5.0.4 to 5.0.9. We are using Unity 2022.3.21.f1. We may try updating to 2022.3.25f soon as kloogens has seemed to find success in that.

Sounds to me like Unity broke the dependency chain for Entities and Burst somewhere in the update pipeline. It’s likely this is not the only version affected, and that AStar may have to find a workaround somehow, since 5.0.4 is working maybe it’s a good idea to bisect back to see what tripped this?

1 Like

Kaleido, I did get it working as I mentioned above.

I also got a response from unity and although I didn’t try it, they did give me instructions on how I could (supposedly) get everything working in my 2023.1.6f1 version I was using previously. If you want those instructions I’ll post them here, let me know

1 Like

Please do post them. My team and I are hoping to solve this issue ASAP.

I couldn’t get the images in this response. I don’t think they’re that important though. Let me know if it helps, I hope it does.

downgrading the com.unity.entities package to 1.0.0-pre.65 version resolve compliation errors. To downgrade the com.unity.entities package to version 1.0.0-pre.65, you can follow these steps:

  1. Open the Package Manager window (Window > Package Manager)

  2. Click the add button in the status bar. The options for adding packages appear.

  3. Select Add package by name from the add menu.

  4. Enter the package Name com.unity.entities and enter the full package version 1.0.0-pre.65

  5. Click Install

After downgrading the package, Unity should recompile your project, and hopefully, the compilation errors you were facing should no longer persist

If you have any questions, concerns, or any additional information about this issue, feel free to reach out.

I have downgraded Entities from 1.0.16 to 1.0.0-pre.65

I have noted that this changed the Burst package version, which is the most likely reason AStar is breaking. AStar expects Burst 1.8.3, which Entities 1.0.0-pre.65 does use.

However, Entities latest, which is 1.0.16, uses Burst 1.8.8. This is quite the direct version conflict.

aron will need to make sure that AStar upgrades its dependencies at some point, as intercompatibility seems to have diverged.

However, this feels like a regression in the dependency tree for aron, as 5.0.4 didn’t have this issue and was pulling Burst 1.8.3 just fine. Even with the version difference it was not complaining as it is now.

Downgrading did not entirely function as expected. The job system is now throwing a few InvalidOperationExceptions, which tells me the ecs system is missing a few things astar is expecting.

I’m going to keep Entities on latest (1.0.16), and revert to astar 5.0.4. we won’t be proceeding any further with investigation on our side because we are out of time.

The issue definitely lies on the differences between 5.0.4 and 5.0.9. Please help out, dev :slight_smile:

I list the minimum supported versions in the package. To then resolve a set of versions which are compatible with each other is the job of the Unity package manager. Though, it is admittedly pretty bad at its job.
I often check that the package works with the latest version of the entities/burst/mathematics/collections packages, and I believe it does work with the latest versions, at least in the more recent versions of Unity. The dependencies for this package are exactly the same as in 5.0.4.

Btw. Listing what errors it gives you will give me more to work with :slight_smile:

I sincerely apologize, since I realize I haven’t been handling this report professionally at all. I am going to pastebin the errors for you in a moment.

Theory is, it’s probably something to do with updating via the package manager instead of installing and uninstalling, artefacts might be getting left behind or something.

I’m convinced it’s not pulling the DLL properly as every error here is a missing symbol type of error (nosuchmethod, invalidoperation, etcetera), the usual thing that happens when dependencies go straight up missing or are incompatible. Note that downgrading back works as expected.

I’m in the process of getting the errors to generate for you and should have them all in within an hour.

I can’t move any further with the investigation until next week due to me not having permission to download the package. However, I can guide you through what we did to find the errors.

  1. Start a project with 5.0.4 and Unity 2022.3.21.
  2. Setup your typical Follower Entity, such as a zombie roaming to a single point.
  3. Run the project once, letting the FollowerEntity reach the target. Everything works fine here.
  4. Now upgrade the project to 5.0.9 via the Update button in the package manager.
  5. Try running again, and watch as the console floods with nosuchmethod and invalidoperation exceptions, citing all of the packages the original post to this issue did.
  6. The console will spit these errors per frame, and the FollowerEntity will sit there and do absolutely nothing, making it clear pathfinder is refusing to do anything at all.

As you can see, the only thing I can think of is utilizing the Update button in the package manager. Something must be causing it to mess with dependencies during the upgrade process.

Which errors in particular? This doesn’t sound like compilation errors.

They aren’t compilation errors, but they all reference the same package names as in the original issue. Maybe it’s unrelated sure, but for now I’m still trying to get investigation moving forward when I can. The API level of things, all of the C# code, including ours, compiles fine. Runtime, however, it starts to act as if the DLLs didn’t link at all.

As I mentioned before, I sadly cannot reproduce the issue myself until I’m back at work next week, however I am asking some teammates to see if they can reproduce the issue and send us the full things. This, however, may take a few days, as the folks who were working on the issue are busy.

I should also note that a fresh project fresh installing 5.0.9 does not have this issue. It only shows up if you use the Update button in the Package Manager.

I do apologise but after weeks of hunting we haven’t been able to reproduce the issue. It seems to have been a fluke where sometimes the Unity Updater just won’t tell Visual Studio where the DLL is when compiling. Very strange, but since upgrading to 5.1.1 (newer version than 5.0.9 which we had issues with in the past), the issue has not come back. I was unable to get the errors in particular.