Support Forum

High polycount and Tile size of procedural planet 4.3.47 beta

I have a very high poly marching cubes planet and the NavMesh path is complaining about vertex : tile size. I don’t see a way to control tile size in NavMesh graphs. Changing the ASTAR_RECAST_LARGER_TILES bool in Optimization doesn’t indicate what the limits are actually being upped to…

Is there a way to change the tile size of a navmesh graph?

Hi

Are you using a navmesh graph or a recast graph?
For a navmesh graph you probably shouldn’t use a vert high poly input. This will just give you slower and lower quality pathfinding. The triangles should be as large as possible, as long as they represent the walkable surface correctly. Do you have a screenshot of this mesh?
With ASTAR_RECAST_LARGER_TILES the vertex limit is raised to 0xFFFFF = 1048575 vertices.

That’s a really high limit! Something else must be going wrong because my whole marching cubes planet is just under 64k (to prevent chunks). But on that note, I didn’t know you could do spherical graphs with Recast - what settings should I use, because no combo I’ve tried seems to work?

edit: lol, just now read back and realized I didn’t say spherical planet. Yeah it’s a sphere - so Navmesh only. But still I can’t figure out why the poly limit is still a problem, unless the RECAST keyword only works on RECAST graphs? Why would it suggest to change that keyword when I’m using a Navmesh then?

Hi

What exact error is it printing? It should be printing the number of vertices it found, and the limit.

Too many vertices in the tile (15362 > 4095)
You can enable ASTAR_RECAST_LARGER_TILES under the 'Optimizations' tab in the A* Inspector to raise this limit. Or you can use a smaller tile size to reduce the likelihood of this happening.

This is not the count, however. My game has a regular-old mesh in the scene for placement and camera setup, and when the game is actually running, it generates the real planet. The real planet is as close to the 64k vert limit as I can go without going over because I haven’t taken the time to chunk it yet. This is the result when I use even the placeholder sphere in a Navmesh. So I’m assuming the full final 50-55k poly sphere is not going to work.

Hmm, are you sure you enabled ASTAR_RECAST_LARGER_TILES?
That 4095 value in the message is the current vertex limit.

Yes but this is a NavMesh graph, not a Recast graph we are talking about. Does that make a difference?

Originally that option only applied to recast graphs. Now it applies to both, but the previous name was kept to preserve compatibility.

Ok I’ll try one more time.

It worked this time. I have some weird custom inspectors enabled and I don’t think the “apply” was actually doing anything - because this time was the first time the dialogue popped up letting me I had to recompile and reload the inspectors. It works with the temporary geo, I’m going to try with the procedural navmesh now. Thank you VERY much for the continued, awesome support.

1 Like

That’s great to hear! :slight_smile:

Oh, and if you enjoy using the package and want to support it even more, a rating and/or review in the asset store helps tremendously :slight_smile: