Support Forum

[Help] I Can't get package by UPM, how to do this success? Thanks~

My content in \Packages\manifest.json:

{
“scopedRegistries”: [
{
“name”: “Aron Granberg”,
“url”: “https://arongranberg.com/packages/0ccf****************************f2/”,
“scopes”: [
“com.arongranberg”
]
}
],
“dependencies”: {
“com.unity.burst”: “1.3.0-preview.9”,
“com.unity.collab-proxy”: “1.2.16”,
“com.unity.entities”: “0.9.1-preview.15”,
“com.unity.ide.rider”: “1.1.4”,
“com.unity.ide.vscode”: “1.1.3”,
“com.unity.probuilder”: “4.2.3”,
“com.unity.test-framework”: “1.1.11”,
“com.unity.textmeshpro”: “2.0.1”,
“com.unity.timeline”: “1.2.12”,
“com.unity.ugui”: “1.0.0”,
“com.unity.modules.ai”: “1.0.0”,
“com.unity.modules.androidjni”: “1.0.0”,
“com.unity.modules.animation”: “1.0.0”,
“com.unity.modules.assetbundle”: “1.0.0”,
“com.unity.modules.audio”: “1.0.0”,
“com.unity.modules.cloth”: “1.0.0”,
“com.unity.modules.director”: “1.0.0”,
“com.unity.modules.imageconversion”: “1.0.0”,
“com.unity.modules.imgui”: “1.0.0”,
“com.unity.modules.jsonserialize”: “1.0.0”,
“com.unity.modules.particlesystem”: “1.0.0”,
“com.unity.modules.physics”: “1.0.0”,
“com.unity.modules.physics2d”: “1.0.0”,
“com.unity.modules.screencapture”: “1.0.0”,
“com.unity.modules.terrain”: “1.0.0”,
“com.unity.modules.terrainphysics”: “1.0.0”,
“com.unity.modules.tilemap”: “1.0.0”,
“com.unity.modules.ui”: “1.0.0”,
“com.unity.modules.uielements”: “1.0.0”,
“com.unity.modules.umbra”: “1.0.0”,
“com.unity.modules.unityanalytics”: “1.0.0”,
“com.unity.modules.unitywebrequest”: “1.0.0”,
“com.unity.modules.unitywebrequestassetbundle”: “1.0.0”,
“com.unity.modules.unitywebrequestaudio”: “1.0.0”,
“com.unity.modules.unitywebrequesttexture”: “1.0.0”,
“com.unity.modules.unitywebrequestwww”: “1.0.0”,
“com.unity.modules.vehicles”: “1.0.0”,
“com.unity.modules.video”: “1.0.0”,
“com.unity.modules.vr”: “1.0.0”,
“com.unity.modules.wind”: “1.0.0”,
“com.unity.modules.xr”: “1.0.0”
}
}

But, None “A* Pathfinding Project” in “Package Manager/ All Packages”. (I haven’t used UPM before.)
I have tried to turn on the VPN(or off VPN).
What can I do? Thanks for you help!

Which version of Unity are you using?

Unity 2019.3.3f1 . Thanks for you reply~

Try adding

"com.arongranberg.astar": "4.3.19"

manually as a dependency in your manifest file and see if that works.

1 Like

:fearful:Bad news, I still can’t download, the speed seems to be 0 (whether or not VPN is turned on).


I started my project as normal, then overwrote manifest.json, and it looked like this.
Loading is stopped.
I need to turn on the VPN to check the forum, so I think it’s right to turn on the VPN, but I still can’t download it.
I’m in China.

The package is quite large, about 70 mb. Do you think you waited enough time?

I waited longer than 30 minutes.
Again, I’m more patient. Thank you for your help~ :grinning:

Hmm… That should be enough even with a pretty slow internet connection.

Can you try to download https://arongranberg.com/packages/0ccf**************************** f2/com.arongranberg.astar/-/com.arongranberg.astar-4.3.19.tgz using a browser? (replace *** with your actual url).

1 Like

That’s great.
Your new method is available for download.
Thank you ~ ~ ~ :grinning: