Errors on import?

When I import the package (I’m using the free version), I get a slew of errors related to missing methods, for example:

Assets/AstarPathfindingProject/Core/Serialization/JsonConverters.cs(62,59): error CS0505: Pathfinding.Serialization.UnityObjectConverter.WriteJson(Type, object)': cannot override becausePathfinding.Serialization.JsonFx.JsonConverter.WriteJson(System.Type, object)’ is not a method

I’m getting these messages on several functions within each of the “convertors” (BoundsConvertor, etc) and they all seem to refer to three functions, CanConvert(), ReadJson(), and WriteJson().

Any ideas as to fixing this?

Hm, never seen that error before.
Try importing to an empty project. If that works without errors, there is probably some conflict with another plugin. Are you using anything else which is using JsonFX?

Also, if you are upgrading, try deleting the AstarPathfindingProject folder and importing again, it might be old files which are not correctly replaced.

Yeah this one didn’t make much sense to me either, I’ve actually used this plugin before (current version) and it worked perfectly fine. After adding in a few features it got a little messy so I restarted it, making it more integrated but not using any extra plugins, for whatever reason it doesn’t work now. I’ve tried deleting the folder and reimporting but had no luck. As far as differences go, the only thing that I have in my new project that I didn’t have before is a custom 3D model, I’m not seeing the connection.

Hm… Well… I can’t really help much then. Sorry.

In my case this error happened cause I had a Static Class with a public enum named ‘Type’. If anyone gets the same error.

If this is not the cause of your error, I suggest importing the Astar project into an empty project and adding your scripts one at a time, to see which scripts are causing conflicts with the Astar Project.