"Class cannot be found"

I have installed the plugin through the Unity Asset Store, then just right after importing notice there were new versions, so I removed the folder from my project and proceeded to download through the Registries window.

After downloading the new version, I noticed some scripts weren’t appearing in the script list, then tried to force-move them to the components list, and received this error attached.

My preferences window also gives this also attached error now. Anyone knows a solution?



Thanks for the attention!

It looks like the package installation is corrupt. Try to delete it and import the package again.

Tried deleting, restarting the project and then installing again just to be sure, still have the same error unfortunately.

I thought maybe I had modified the manifest file with something wrong, but since the package appears normally I don’t think that’s the situation

Do you have a compatible version of Unity? Unity 2022.2.10f1 and up.
And can you verify that the dependencies of the package are installed?

Also make sure there is no Assets/AstarPathfindingProject folder.

I’m using 2022.3.16f1 at the moment. It seems I was missing the Collections dependency, installed but unfortunately the error is still there, didn’t notice before but there are a lot of entry-point errors after I install the package, the log contains information regarding my machine and project, can I share through email in private?