Can't Import Package Into Unity 5.3.2

I downloaded the free A* Pathfinding project 3.8.2 from the website and when I try to import it into Unity I get one of two results:

  1. Failed to import package with error: Couldn’t decompress package. This is an error that shows up in the console

  2. The package decompresses just fine and I get a pop up window that states “Nothing to import! All assets from this package are already in your project.” This is a problem because the project is completely empty. I made a brand new project to test out the A* algorithm and the first thing I try to do is import this project.

I also tried to download the free Beta Version but I can’t even download that. When I click the button it takes me to a webpage that says “Invalid Authentication”.

If it helps, I’m running Windows 10 Pro and Unity 5.3.2.


Odd. It works fine for me (I tested in 5.2 though). There might have been a problem with my download script corrupting the file, I have changed it a bit now, see if it works.

Yeah, I had mistakenly marked the free beta version as requiring a pro license, I have fixed it now, thanks for reporting it.

Yes, the changes you made seem to have fixed it. I am now able to download and import the A* Pathfinding Project package into Unity!