Support Forum

Can't download Beta version via Unity Packagemanager

I have tried several times now to get the newest beta in the Unity package manger following the guidelines without success.

I put in my unity store invoice number, the generated code was placed into the manifest.xml, running Unity 2019.3.15 but the packagemanager still shows the old 4.2.15 version.

Would love to know what I am doing wrong,

Thanks!

That sounds wrong. It’s not an xml file, it should be a json file.

Sorry :(, it is a json file. My bad. I am sure I am using the correct file.
manifest.json in ProjectName/Packages

{
“scopedRegistries”: [
{
“name”: “A* Pathfinding Project”,
“url”: “https://arongranberg.com/packages/SECRET”,
“scopes”: [
“com.arongranberg.astar”
]
}
],
“dependencies”: {
“com.unity.2d.sprite”: “1.0.0”,
“com.unity.cinemachine”: “2.5.0”,
“com.unity.ide.rider”: “2.0.3”,
“com.unity.nuget.newtonsoft-json”: “2.0.0”,
“com.unity.postprocessing”: “2.3.0”,
“com.unity.quicksearch”: “1.5.3”,
“com.unity.settings-manager”: “1.0.2”,
“com.unity.textmeshpro”: “2.0.1”,
“com.unity.timeline”: “1.2.14”,
“com.unity.ugui”: “1.0.0”,
“com.unity.xr.legacyinputhelpers”: “2.1.4”,
“com.unity.modules.ai”: “1.0.0”,
“com.unity.modules.animation”: “1.0.0”,
“com.unity.modules.assetbundle”: “1.0.0”,
“com.unity.modules.audio”: “1.0.0”,
“com.unity.modules.cloth”: “1.0.0”,
“com.unity.modules.director”: “1.0.0”,
“com.unity.modules.imageconversion”: “1.0.0”,
“com.unity.modules.imgui”: “1.0.0”,
“com.unity.modules.jsonserialize”: “1.0.0”,
“com.unity.modules.particlesystem”: “1.0.0”,
“com.unity.modules.physics”: “1.0.0”,
“com.unity.modules.physics2d”: “1.0.0”,
“com.unity.modules.screencapture”: “1.0.0”,
“com.unity.modules.terrain”: “1.0.0”,
“com.unity.modules.ui”: “1.0.0”,
“com.unity.modules.uielements”: “1.0.0”,
“com.unity.modules.umbra”: “1.0.0”,
“com.unity.modules.unityanalytics”: “1.0.0”,
“com.unity.modules.unitywebrequestwww”: “1.0.0”,
“com.unity.modules.vr”: “1.0.0”,
“com.unity.modules.xr”: “1.0.0”
}
}

Hmmm… I’m not sure what the issue could be in that case.
What if you try to specify the dependency in the manifest.json file directly?

"com.arongranberg.astar": "4.3.28"

That worked. Just the examples are missing. Can I get them somewhere else?

Btw: I bought a few different plug-ins with one purchase, maybe that is the problem?

You can download them via the package-manager too. There is a button there.
See the bottom of this page: https://arongranberg.com/astar/download_upm (after you have entered your invoice number)

wonderful. I was still looking at the old 4.2.15 entry, not the newly installed and didn’t see it. All good now! Thank you! :smiley:

1 Like