Asmdef issue with nested "PackageTools" asmdef


I’m running 4.3.39 on Unity 2020.2.0f1.

I have my project’s asmdef which is referencing the AstarPathfindingProject asmdef.

In my code I am able to see the Pathfinding code and create a variable to reference the Seeker component.

However when I try to use it via m_Seeker.StartPath(...) I get an error:

error CS0012: The type 'VersionedMonoBehaviour' is defined in an assembly that is not referenced.

It appears that VersionedMonoBehaviour is located in a sub asmdef called PackageTools but oddly enough that doesn’t show in the Inspector:

Screen Shot 2020-12-21 at 3.17.47 PM

Even though it is physically there on the file system:

Screen Shot 2020-12-21 at 3.18.15 PM

I’ve tried reimporting the package, removing and readding the assembly but no dice.

Any thoughts?


I updated to Unity 2020.2.1f1 today and now I can see the nested asmdef for PackageTools.

I was able to add it but there was a new error for the MonoBehaviourGizmos. I found that in the ALINE asmdef and added that as well and now things compile.

Here’s a picture of the asmdef for my project in case this helps anyone else:

Screen Shot 2020-12-23 at 6.47.42 PM

1 Like

Thanks for this! I couldn’t find the Drawing file.

@aron_granberg this is a little unintuitive, I tried to find any mention of it in the documentation and couldn’t seem to. Is this a surprise effect on games using Assembly Definition files?

I’ll add it to the installation instructions.

Adding the dependencies would be required for all packages you install, if you are using asmdef files.

I’ve added this to the installation instructions now. Do you think this would have helped you sufficiently?