5.1.2 upgrade crashing on Mac M1

If I disable Astar, my scene runs fine, but when I reenable it, it hangs every time I start the scene on the import assets step with nothing useful getting logged. We were using 4.2.19 with no issues on Mac M1.

Tried it on an older Intel Mac and no issues. Also tried it on Windows and no issues.

We are using the new local avoidance, a recast graph, and the RichAI.

Any info would be much appreciated! Thanks!


It’s hard to say anything without any error messages of any kind.
There’s nothing in the editor log file?

Correct. There is nothing beyond the normal start up messages in the editor.log file.

Strange. I have not heard of any other users seeing anything similar.
It sounds like a Unity bug to me, since it’s a hard crash.

Try to remove whatever graph you are using, but leave the AstarPath component as is. That might be useful in tracking it down.

Yes, it no longer crashes if I remove the two recast graphs.

And in fact, now that my scene finally finished importing the assets (with the graphs removed) I am still able to run the scene even after I add them back!

Oh? So the issue is gone?
Very strange. But to me that really points to a Unity bug… :confused:

Yeah, the issue is now gone. Very strange.