4.3 beta version cannot be found in Unity Package Manager

I’ve been using A* Pathfinding well on 4.2 version since my purchase. My project heavily relies on local avoidance, so “significantly” increased efficiency for 4.3 beta sounded very nice, so I wanted to try that. Except it’s very difficult to do so.

I followed the instructions and edited the json file as well, (with the unique link that I shouldn’t share with anyone) but A* Pathfinding Project does not appear in All packages menu of the Package Manager.

I tried installing different versions of Unity Editor (other versions of 2019.3, 2019.4, 2020.1), reinstalling, refreshing, turn off-on the computer, re-importing asset files, deleting previous versions of A* Pathfinding… but none of them can locate A* Pathfinding Project in the Package Manager in the “All packages” menu.

I can find and download 4.2.15 version of A* Pathfinding from “My Assets” just fine, but cannot figure out how to download 4.3 beta version of the A* Pathfinding Project. I don’t see many people having this issue, so I feel like I’m missing something. Any help would be appreciated. Thanks,


That’s odd. You could try manually adding ‘com.arongranberg.astar: VERSION’ to your manifest.json file and see if the package manager manages to find it then… Let me know how it goes.

1 Like

Thanks! That did work.

To specify what I did, I simply added “com.arongranberg.astar”: “4.3.33”, on the first line of the dependencies section of the manifest.json file, in addition to the scoped registry thing you have to copy-paste in according to your instruction. The current unity version I am using is 2019.4.8f1 Personal.

Now, the package manager shows me the 4.3.33 version is available to be downloaded. Before I added that line in the dependencies, “My registries” tab didn’t even exist, so it was a new thing that popped up which resolved my issue.

Again, I appreciate your help!

This fix worked for me as well, thanks. You might want to update the instructions for the beta download on your web page if this is the regular way to install now. I got stuck in the same loop where it installs 4.2.15.

I think this is just a temporary Unity bug with the package manager. Custom registries should be visible in the package manager.


Just wanted to say I too had to follow this workaround today to install the beta version on Unity 2020.2. For some reason the private registry doesn’t show up in package manager until you bump the package version in the manifest.json.

Maybe this thread should be pinned (or instructions included in the download page) because it wasn’t easy to find it via google.

Same here… had to add “com.arongranberg.astar”: “4.3.39”, to manifest.json.

Step #6 in the directions here: https://www.arongranberg.com/astar/download_upm# states: " Select Packages: All in the top left corner of the window.", but in Unity 2020.2.0 there is no “Packages-all” in the top left corner.

It does exist in Package Manager/My Assets, but it won’t let me choose anything higher than 4.2.15.

@Ph0t0n it looks like Unity has put the custom registries in another tab now (I have updated the install page). You should be able to find a tab called ‘Packages: My Registries’. At least that works for me using Unity 2020.2.