[4.1.8] Bug caching

I tried debugging it for some time, but I cannot find anything wrong in the code.
The zip library itself hasn’t been updated since 2011 it looks like, so I don’t think there are any updates to it that fixes this bug unfortunately.

Ok Thks for support, I will run it without ZIP but hope you will find an alternative :slight_smile:

So if I use ASTAR_NO_ZIP indeed no more problem but graph cache pass from 6Mb to 30 mb so I definitely need an alternative


Try this:

Open the SimpleZipReplacements.cs file and replace this line:

 var writer = new System.IO.BinaryWriter(stream);


var writer = new System.IO.BinaryWriter(new System.IO.Compression.DeflateStream(stream, System.IO.Compression.CompressionMode.Compress));

and this line

var reader = new System.IO.BinaryReader(stream);


var reader = new System.IO.BinaryReader(new System.IO.Compression.DeflateStream(stream, System.IO.Compression.CompressionMode.Decompress));

You will have to reconfigure your graphs again after this change unfortunately.

I tried something because at a certain moment ZIP cache worked for me. And when I set my graph size to 1200*1200 ( target size ), ZIP caching works so problem solved :slight_smile:

1 Like

Getting this same problem using 4.2.2 Is there a real fix? Changing scripting defines is not an option for me.


There is no real fix at the moment. However as more and more people are now using the newer .net framework backend it might be possible for me to switch to using the .net built-in zip compression which should hopefully solve it as well. This issue only seems to happen for veeery specific configurations however, so changing your grid size to something slightly different should hopefully resolve it for the time being.