Stop agents from snapping to navmesh

When I apply physics to my agents, they sometimes decide to snap to the nearest surface, causing very odd effects. An example of this is the agent being thrown into the air, and then snapping to a nearby pillar.

Is there any way to avoid this issue? I’ve tried making the seeker do “original” points, instead of surface, but that hasn’t worked.


The AIPath component has a field called “Constrain To Navmesh”. You can disable it to get the behavior you want.

Oh I see! What about for RichAI? It looks like it doesn’t have that field


The RichAI component needs to be on the navmesh at all times by construction. It cannot really navigate if it’s not on the navmesh.