Support Forum

RVO controllers do a poor job pathing around eachother

I can have some pretty simple situations, such as one unit wanting to path to the opposite side a parked unit, and although there are obvious paths around the parked unit, it simply rams its head into the parked unit.

Does RVO not attempt to path around other RVOs? Or how does it work exactly?

There may very well be an implementation issue on my side, and I guess I need more details to help guide me in diagnosing this.

Thanks as always!

Strangely, I was attempting to edit or delete my post, but it says I need administrator access to do so. I don’t recall that being a thing in the past…

Anyway, I have continued to look into this. I removed NavMeshCuts from halted units, and noted the radii wasn’t being correctly applied to the RVOControllers. Those two changes seemed to fix the issue of moving units ramming into parked units.

I haven’t specifically tried the issue that brought me here originally, which is having a big blob of parked units, and seeing if a unit will path around them, or get stuck in the blob. But good news is I haven’t seen units getting stuck on each other the last day or so.

@ZoopTEK Are you using beta ?
I’m also facing same issue with RVO agents.

I recently moved to the beta after being recommended to be my aron_granberg.

Regarding your issue, I admittedly haven’t been explicitly testing big blobs like that. That being said, blobs can occur in my game and they don’t seem to give up like yours do.

Do you have any code where if a unit takes too long to move, they simply give up?

Yeah, I was just testing asset before integrating it. In my example there are around 25 agents and only few moves other just gives up.(like shown in gif) But it works well in 4.15 with same setup.

Unfortunately, I can only tell you what I’ve done: removed NavMeshCuts on idle units, fixed radii to be equal or greater than the agent’s radius, on non-player units I disabled the “lock once arrived” option.

If I were to take a wild guess, it looks like some of your stuck units are “locking” themselves prematurely.

Ultimately @aron_granberg will be the best one to answer your questions.

No worries I guess I found the solution there is stop movement when crowded option. Disabling it solves the problem.