Nothing Works in 2020.1.7

Basically, after I import, all the scripts in the folder are shown as white in the project tab and I cannot open them directly from unity, I don’t think unity even recognizes that they are scripts. On top of that, I cannot use scripts, unity treats them as if they don’t exist. I don’t know if this is a unity bug or because this project has not been updated to 2020 yet.
When I had used Astar earlier in 2019, it had worked fine.
Thanks in advance!


Are you seeing any errors in the console?

No, I don’t see any.
When I search for the component it just doesn’t show up as well as when I go into the package, the scripts are shown as blank files (not c# scripts and cannot be opened in VSCode)

Try to delete the package and import it again.

I tried that and it did not work, but I just made a new project with the same unity version and it worked, pretty weird but I guess its fixed! Thanks for the quick replies!

1 Like

I have a similar issue, the system is not working in the project where i want to use it, not even the example scenes, if i hit play nothing happens, no log errors, nothing. If i import this in a new project, everything works fine, I have tried in Unity 2019.4.11f1, Unity 2019.4.12f1, and 2020.1.9f1, I have also tried A* 4.2.15 version and also 4.3 beta, same result, can you help me?

I have an update, this time in the RaycastExample2 i got this error when i hit play:

NullReferenceException: Object reference not set to an instance of an object
Pathfinding.NavmeshUpdates.Update () (at Assets/AstarPathfindingProject/Navmesh/NavmeshUpdates.cs:166)
AstarPath.Update () (at Assets/AstarPathfindingProject/Core/AstarPath.cs:859)

and this one:

NullReferenceException: No AstarPath object found in the scene. Make sure there is one or do not create paths in Awake
Pathfinding.Path.Reset () (at Assets/AstarPathfindingProject/Core/Path.cs:527)
Pathfinding.ABPath.Reset () (at Assets/AstarPathfindingProject/Pathfinders/ABPath.cs:213)
Pathfinding.Path.Pathfinding.IPathInternals.Reset () (at Assets/AstarPathfindingProject/Core/Path.cs:829)
Pathfinding.PathPool.GetPath[T] () (at Assets/AstarPathfindingProject/Core/Misc/PathPool.cs:82)
Pathfinding.ABPath.Construct (UnityEngine.Vector3 start, UnityEngine.Vector3 end, Pathfinding.OnPathDelegate callback) (at Assets/AstarPathfindingProject/Pathfinders/ABPath.cs:96)
Pathfinding.Seeker.StartPath (UnityEngine.Vector3 start, UnityEngine.Vector3 end, Pathfinding.OnPathDelegate callback) (at Assets/AstarPathfindingProject/Core/AI/Seeker.cs:397)
Pathfinding.Seeker.StartPath (UnityEngine.Vector3 start, UnityEngine.Vector3 end) (at Assets/AstarPathfindingProject/Core/AI/Seeker.cs:384)
Pathfinding.AIBase.SearchPath () (at Assets/AstarPathfindingProject/Core/AI/AIBase.cs:445)
Pathfinding.RichAI.SearchPath () (at Assets/AstarPathfindingProject/Core/AI/RichAI.cs:252)
Pathfinding.AIBase.Update () (at Assets/AstarPathfindingProject/Core/AI/AIBase.cs:379)

This not happend in a new project.

I’m not sure what could cause that. Are you using any managers that might end up messing things up?