A* Pathfinding Project

Grid Graph doesn't respect my slope limits


#1

Hi!
I have a Grid Graph with a 60 degrees limit for my slopes but I keep getting navmesh over 90 degres walls and empty wholes (such as caves).
I’m attaching an screenshot and my settings, what am I doing wrong? Thanks


#2

Hi

It’s a bit of an undocumented feature (implemented a long time ago when several unity tools used the same convention) that setting max climb to zero treats it as allowing any climb value.
Thus even though the slope of the terrain is less than 60 degree nodes may be connected using the ‘max climb’ limit.

I would suggest you set max climb to something like maybe 1 or 2.

Also I would recommend that you use the layered grid graph instead of the normal grid graph if you want to be able to detect caves. The normal grid graph is limited to a single layer of nodes.


#3

Hi Aron! Thanks so much for the quick reply!
I changed to Layered Grid Graph and it worked like a charm!
Thanks so much :slight_smile: