Graph Does not Persist Through Play Mode


When I first started using this asset I was able to run a recast scan that would persist until I chose to delete it or replace it. I could push play and my characters would immediately start moving as they should on that graph. Now for some reason my graph seems to be deleting itself when I push play so my characters just stand there until I manually run the scan again. Exiting the graph does not allow the graph to return after I exit play mode either.

I have tried both with and without the “Scan on Awake” option but it doesn’t make any difference. I have updated several times since I realized that this was happening, hoping that it was just a bug that would get fixed in a later version. I’m on the latest beta version currently and have had no such luck.

I also noticed that I’m getting an “Object reference not set to an instance of an object” error on my scene’s main A* GameObject whenever I push play but I have not been able to track it down to anything specific in the settings. I have no idea what could be missing.

Is there any setting that would cause this behavior?


Only graph settings persist to play mode. If you have Scan On Awake enabled, it should scan the graph when you start (unless you have graph caching enabled). That error message could be important, do you think you could post the full stack trace?

So I’m not sure what has changed but the problem seems to have resolved itself. I can now use the graph caching option and it loads as soon as the game starts. It’s a bit strange because I tried this option many times over the last few weeks and never got it to work. Odd, but I’ll take what I can get.

Thanks for the help.

1 Like