Fixing up a recast navmesh

I’ve been experimenting with Recast graphs to allow navigation on a level that includes stairs. I’ve been struggling with getting settings that worked for a particular set of steps from Synty’s Fanstasy pack. The graph would never seem to get to the top/bottom and would have a hole in the middle. I wondered first if I could manually fix this up (using new node links), but noticed that a RichAI wouldn’t follow it even though I’d added connections - which I guess makes sense - no triangles. I finally managed to get a Recast graph to cover the stairs by setting a cell size of 0.02 (and clearly now it takes a long time!)

I’m wondering:

  • Is there a better way for me to get the recast graph to cover the area I’m looking at (e.g. having a higher resolution just for this tiny area of the level)
  • Can I add connections myself and get the path follower to follow them


Try to rasterize colliders instead of meshes (setting on the recast graph).
If the stair mesh is very complex, there might be some parts of it that technically have a too steep slope for the agent to traverse, even though it is a tiny region. A simplified collider (maybe even just a slope, no steps at all) can make it much easier to generate a good navmesh.

1 Like

Great advice, thanks. It works fine with a little fiddling I now have a much better mesh.