Support Forum

Can't use any of the classes after importing into my project?

Sorry if this is a frequent question, but I’ve looked around everywhere and can’t find help. I’ve just imported the free 4.2.17 version into my project, and all of the premade scripts like the Pathfinder and Seeker get imported just fine, but whenever I try to write my own script using the imported classes it just doesn’t think they exist.

As you can see i’m using the Pathfinding namespace but it doesn’t give me the Path class to use. I’ve tried creating a new project and importing it into that just to test, and there it works just fine, so it seems to be something with this project specifically. I’ve tried deleting and re-importing everything, though I could have been doing that incorrectly. If anyone knows whats up, I would really appreciate it.

Hi

Usually this because of either:

  1. You are using assembly definition files, but you have not added the A* Pathfinding Project as a dependency.
  2. Your .csproj files are not rebuilt. You can rebuild them from inside Unity (just deleting those files also works I think).