Avoidance doesnt care about radius

I’ve tweaked so many setting,
but for some reason nothing works as intended,
For example I can set the radius to be huge on these guys but something is making them want to run directly into eachother…

Any ideas what I am doing wrong? I’ve gone through all the tutorials but I just cant get this plugin to work as desired

That looks very strange. Are the example scenes working for you?
Do you have any other components on the agents?
What are your RVOSimulator settings?

  1. Example scenes used to work, but since I tried removing the beta version you had me install things have been throwing warnings around, and I no longer have the example scenes installed. I DM’d you awhile back about all this,

  2. Seeker, AIPath, AI Destination Setter, RVO Controller, RaycastModifer, Funnel, NavmeshCut

  3. I’ve been playing with them, they dont seem to matter

I notice in your video that the agents always seem to have a rotation of (0,0,0) which seems strange. It also looks strange that the Nav gameobject seems to be a child of the actual character. The movement scripts should always be attached to the character’s root GameObject since that’s the one that moves and rotates.

I all i want from the navmesh is a movement direction and I rotate and move my character via rootmotion, I don’t want the nav agent to move me, simply to give me a rotation vector

private void AiMovement(Transform target)
if (_aIDestinationSetter)
_aIDestinationSetter.target = target;

    if (_aiPath && _aIDestinationSetter.target != null)

That simply will not work with the local avoidance system as it is built.
The steering target doesn’t even include local avoidance information.

I answered a bit more in your PM thread.

I turned off RaycastModifer, Funnel, NavmeshCut for now.

Also turned offAIPath.Enable Rotation,
they still seem to rotate for unknown reasons

The GameObject rotation is always (0,0,0) so the AIPath/RVOController scripts are at least not applying any rotation.

Yeah but I am getting the desired rotation from :


So why would you expect it not to rotate? I’m assuming that HandleRotation rotates it towards the steering target?
By using the steering target property you are essentially bypassing most of the AIPath’s movement code, including the code that rotates the agent. But instead you seem to be rotating it yourself.

I want it to rotate to face the direction the agent wants to travel (the green path)

however the agent spins in a 360 randomly while running along that path.

There is no intellisense comment for steering target, only the .targetDirection is obsolete and to use it.


Yeah I need to get on writing that doc tool to automatically rewrite the docs so that intellisense will understand it…
You can find the docs for that here: https://www.arongranberg.com/astar/documentation/dev_4_3_39_4d73c4d8/aipath.html#steeringTarget

so i am using that right,

then why the 360s?

I can make it even simplier logic and the 360s get worse:


Yeah so i reinstalled the example scene files, and it just seems like everythings messed up

Can you please advise the right way for me to:

un-install from the beta, then reinstall the live version?

and also how to un-install from the live and reinstall from the live-version

I need to get this working in this project, I cant start from scratch

To uninstall you can remove the beta using the Unity package manager then delete the example scenes folder.
Then either install the beta or the non-beta, your choice.

As for all the turns, your ‘pick next waypoint distance’ might be too low.
See the documentation for more info: https://arongranberg.com/astar/docs/aipath.html#pickNextWaypointDist

There is no remove via the package manager??

and the code you had me add to the manifest for the beta makes unity super angry if i try to use it with the live version, so i removed that as well.

I deleted the AStar Folder, removed all ref’s from script/scene components , Restarted Unity twice and I think its finally accepted the change.

Ive tried lengthing and shortening the waypoint distance many times

I will try a complete fresh setup of everything tmrw

If you imported the beta version it should show up in the package manager (same way as you installed it), and there should be a ‘remove’ button.
However, if you imported it from the asset store it may show up as a folder in the project itself. In that case you can just delete that folder.