A* Pathfinding Project

AILerp No Longer Accessible


#1

I just updated my Pathfinding to 4.3.14 and I’m now having a problem where my custom script does not recognize the AILerp name. I have the using Pathfinding code at the top. Nothing has changed except the fact that I updated the package. What is the new way of accessing that script?


#2

Hi

Are you using assembly definition files? In that case you may have to add a reference to the AstarPathfindingProject.asmdef.


#3

I see. I think that is exactly my problem. How would I go about doing that? I’ve createdt he reference file and I set it to AstarPathfindingProject, but I am getting this now: https://i.imgur.com/0wN1UMD.png


#4

Hi

You should not create another asmdef file. If you are already using one you should update it, if you are not using one already then the error comes from something else.


#5

Ooh, ok. I see the missing references, but what do I need to put there?

I don’t see the pathfinding namespace on my list of options.


#6

I’m pretty sure that’s the pathfinding librarys own .asmdef file, not yours.

You can read more about asmdef files here: https://docs.unity3d.com/Manual/ScriptCompilationAssemblyDefinitionFiles.html

Note that if you are not using asmdef files then Unity will just give you access to everything and you don’t have to care about them.


#7

I don’t think I am. Before hand, all I had to do was type in “using Pathfinding” and it worked just fine. Are you saying that I can just get rid of the asmdef file and it should work like normal?


#8

You should not have to get rid of the pathfinding library’s asmdef files. If you don’t have any .asmdef files outside of that folder then you shouldn’t have to do anything.

Can you verify that you are not getting any compiler errors from anything else?
Are you sure you spelled AILerp correctly?


#9

I can confirm:

I didn’t change my scripts, I just updated my Astar package. The scripts worked before, so I think unless AILerp was changed into AlLerp on your end (with a lowercase L) or something, my scripts should be fine.

These are the only compile errors I am getting.


#10

Try to delete your AstarPathfindingProject folder and reimport the package again.


#11

I get the same problem after doing that.


#12

Have you followed the installation instructions: https://www.arongranberg.com/astar/documentation/dev_4_3_14_5fe3aebd/installation.html?


#13

No, I didn’t. Thank you for the link! It looks like I am missing the entities package, collections and jobs packages. I’ll install those and let you know the results!


#14

After installing those packages, I don’t get those 2 particular errors again, but I get 39 new errors stemming from the drawing folder. The scripts are CommandBuilder.cs, DrawingData.cs, and DrawingBuilder.cs.

After installing the packages, I also deleted the AstarPathfinding folder and reimported it.


#15

Which version of the collections package are you using?
Are you sure you did not turn off unsafe code on the ALINE.asmdef file?


#16

I am using 0.6.0 Preview 9.
I Imported it fresh and did not alter any of the imported files.

This is my ALINE file:


#17

For me Collections 0.6.0 (preview 9) and Burst 1.3.0 preview 4 works out of the box.
Make sure you right click on some random script and reimport it afterwards, unity is sometimes bad at recompiling when new packages have been imported in the package manager.


#18

This did not work for me. I’ve reimported it multiple times and tried different versions of burst and collections packages. I get the same errors.


#19

I’ve managed to reproduce the issue.
It seems like the Unity collections package version 0.6.0 introduced a backwards incompatible change.
You can downgrade to a version earlier than that and it will (hopefully) work. I will release a fix for this soon.

If you get a message the unsafe append buffer cannot be found at all, make sure you have Burst 1.2.3 installed and if you still get it then make unity reimport all assets (I had to do this as otherwise it would just use some cache which was not up to date).


#20

I have now uploaded beta version 4.3.15 which fixes the Unity collections 0.6.0 incompatibility issue.