2D A* weird behaviour (solved)

I have a weird behaviour with my IA. First of all I put the enemies in the map waiting for someone who collides with their trigger detector. When that happens, I set the AIDestinationSetter.Target with that transform who collided, I set the canMove to true and everythings works well. But, when the player kills the enemy, I don’t destroy the enemy I only set the canMove to false and reset the target to null, after 5 seconds to revive, the enemy is like in the beginning, waiting someone who collide with their trigger. After I collide with the trigger, the enemy sets well the target but doesn’t move! and canMove is set to true.
And this doesn’t finish here, If I hit it again, this makes the chase function works again, the enemy moves correctly.
So, what I can’t understand is, why the enemy doesn’t move after reseting the target attribute.
I tried to stop the path calculations while is dead but doesn’t work either.
I can send a video if that helps.

Well, after testing and tracking everything it was my fault. I used freeze constraints of the rigidbody when the skeleton is hit … be aware of that XD